Toontrack - EZmix 2 v2.1.4 + Expansion Bundle (Jan 2019)

Following the success of Toontrack’s EZmix, the new and completely overhauled EZmix 2 continues to build on the same fundamental idea: having pro-designed effect chains for instruments and channels found in every recording session combined in one powerful mixing tool. With the vast collection of ready-made presets, mixing music is not only easy and incredibly fast – you end up with results second to none.

All the previous functionality and content from EZmix is still intact and working in EZmix 2. The major difference however, is that the new and revamped version comes with settings based on high-tech mastering effects, new reverb algorithms, guitar/bass amp and cab simulation, a completely revised interface and a large core content boost. Essentially, EZmix 2 is a mixing engineer, mastering suite and guitar/bass amp all rolled up into one package. Start mixing, its EZ!

Features of Toontrack EZmix 2 v2.1.4
Bug fixes in version 2.1.4:
– The internal AU name has been changed back from “EZdrummer 2” to “EZdrummer”, which it was in 2.1.1 and earlier, to restore save file compatibility in some hosts.
– In Drumkit from Hell, if a sound from another expansion was loaded on an instrument, clicking on that instrument could lead to a crash in some cases.
– Clicking the tempo button under the song track in Toontrack solo could lead to a crash.
– If the User MIDI folder could not be accessed or created, the plug-in crashed when instantiated.
– Dragging across articulation lists in Edit Play Style did not preview any sound.
– Dragging from the Browser had wrong y coordinate.
– The red translucent block that marks the current recording sometimes became too long when a loop endpoint was reached, and it no longer overlaps itself in a loop.
– The following is now disabled while recording: moving the playhead or loop area, Undo/Redo, song track context menus, loop toggling and a few more things.
– Up/down arrow keys in the Browser should work in more hosts on Mac now.
 System Requirements
Windows XP | Vista | 7 | 8 | 8.1 | 10 [32-bit | 64-bit]
Mac OS X 10.7 | 10.8 | 10.9 | 10.10 | 10.11 | macOS Sierra | High Sierra

Share this

Related Posts

Previous
Next Post »